neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。

杭电ACM 1012 u Calculate e

u Calculate e

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11752    Accepted Submission(s): 5028



 

Problem Description
A simple mathematical formula for e is



where n is allowed to go to infinity. This can actually yield very accurate approximations of e using relatively small values of n.
 


 

Output
Output the approximations of e generated by the above formula for the values of n from 0 to 9. The beginning of your output should appear similar to that shown below.
 


 

Sample Output

	
n e
- -----------
0 1
1 2
2 2.5
3 2.666666667
4 2.708333333

 

#include <stdio.h>
int main(){
    double sum;
    int n, i, l;
    printf("n e\n");
    printf("- -----------\n");
    printf("0 1\n");
    sum = 1;
    l = 1;
    for (n=1; n<=9; ++n){
        l *= n;
        sum += 1.0/l;
        if (n <= 2){
            printf("%d %g\n", n, sum);
        }
        else{
            printf("%d %.9lf\n", n, sum);
        }
    }
    return 0;
}

杭电ACM 1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15522    Accepted Submission(s): 8168



 

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 


 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 


 

Output
Print the total time on a single line for each test case.
 


 

Sample Input

	
1 2
3 2 3 1
0
 
Sample Output

	
17
41

 

#include <stdio.h>
int main(){
    int n, t, l, r;
    while (scanf("%d", &n) == 1){
        if (n == 0){
            break;
        }
        r = 0;
        l = 0;
        while (n-- != 0){
            scanf("%d", &t);
            if (t > l){
                r += (t-l)*6;
            }
            else{
                r += (l-t)*4;
            }
            r += 5;
            l = t;
        }
        printf("%d\n", r);
    }
    return 0;
}

杭电ACM 1001 Sum Problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 108140    Accepted Submission(s): 24596



 

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 


 

Input
The input will consist of a series of integers n, one integer per line.
 


 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 


 

Sample Input

	
1
100
 
Sample Output

	
1

5050

 

#include <stdio.h>
int main(){
    int n, sum;
    while (scanf("%d", &n) == 1){
        sum = 0;
        while (n != 0){
            sum += n--;
        }
        printf("%d\n\n", sum);
    }
    return 0;
}




Host by is-Programmer.com | Power by Chito 1.3.3 beta | © 2007 LinuxGem | Design by Matthew "Agent Spork" McGee