杭电ACM 1008 Elevator - neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。

杭电ACM 1008 Elevator

neuxxm posted @ 2011年5月19日 23:13 in 杭电ACM 解题报告 with tags Math Math_求和 , 1863 阅读

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15522    Accepted Submission(s): 8168



 

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 


 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 


 

Output
Print the total time on a single line for each test case.
 


 

Sample Input

	
1 2
3 2 3 1
0
 
Sample Output

	
17
41

 

#include <stdio.h>
int main(){
    int n, t, l, r;
    while (scanf("%d", &n) == 1){
        if (n == 0){
            break;
        }
        r = 0;
        l = 0;
        while (n-- != 0){
            scanf("%d", &t);
            if (t > l){
                r += (t-l)*6;
            }
            else{
                r += (l-t)*4;
            }
            r += 5;
            l = t;
        }
        printf("%d\n", r);
    }
    return 0;
}

登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter
Host by is-Programmer.com | Power by Chito 1.3.3 beta | © 2007 LinuxGem | Design by Matthew "Agent Spork" McGee