杭电ACM 1021 Fibonacci Again - neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。

杭电ACM 1021 Fibonacci Again

neuxxm posted @ 2011年5月20日 09:50 in 杭电ACM 解题报告 with tags 数列 数列_循环节 , 2059 阅读

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14170    Accepted Submission(s): 6581



 

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 


 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 


 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 


 

Sample Input

	
0
1
2
3
4
5
 
Sample Output

	
no
no
yes
no
no
no

 

#include <stdio.h>
int main(){
    int n, t;
    while (scanf("%d", &n) == 1){
        t = n&7;
        printf("%s\n", t==2 || t==6 ? "yes" : "no");
    }
    return 0;
}

登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter
Host by is-Programmer.com | Power by Chito 1.3.3 beta | © 2007 LinuxGem | Design by Matthew "Agent Spork" McGee