neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。

杭电ACM 1017 A Mathematical Curiosity

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10170    Accepted Submission(s): 3078



 

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 


 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 


 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 


 

Sample Input

	
1

10 1
20 3
30 4
0 0
 
Sample Output

	
Case 1: 2
Case 2: 4
Case 3: 5

 

#include <stdio.h>
int a2b2[101][101];
int ab[101][101];
int a[101];
int main(){
    int zz, z, n, m, i, j, b, r;
    for (i=1; i<=100; ++i){
        a[i] = i*i;
    }
    for (i=1; i<=100; ++i){
        for (j=1; j<=100; ++j){
            a2b2[i][j] = a[i]+a[j];
            ab[i][j] = i*j;
        }
    }
    b = 0;
    scanf("%d", &zz);
    while (zz-- != 0){
        if (b){
            printf("\n");
        }
        b = 1;
        z = 0;
        for (;;){
            scanf("%d %d", &n, &m);
            if (n==0 && m==0){
                break;
            }
            r = 0;
            for (i=1; i<n; ++i){
                for (j=i+1; j<n; ++j){
                    if ((a2b2[i][j]+m)%ab[i][j] == 0){
                        ++r;
                    }
                }
            }
            printf("Case %d: %d\n", ++z, r);
        }
    }
    return 0;
}




Host by is-Programmer.com | Power by Chito 1.3.3 beta | © 2007 LinuxGem | Design by Matthew "Agent Spork" McGee