neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。

杭电ACM 1004 Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28869    Accepted Submission(s): 9266



 

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 


 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 


 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 


 

Sample Input

	
5
green
red
blue
red
red
3
pink
orange
pink
0
 
Sample Output

	
red
pink

 

#include <stdio.h>
#include <string.h>
#define N 390
const char C = 'a'-1;
struct bal_t{
    char color[16];
    int fre;
}bal[N+1];
int hash(char s[]){
    int r = 0;
    char *p = s;
    char c;
    while ((c=*p++) != '\0'){
        r += c-C;
    }
    return r;
}
int main(){
    char s[16];
    int n, i, t, max, max_i;
    while (scanf("%d", &n) == 1){
        if (n == 0){
            break;
        }
        for (i=0; i<=N; ++i){
            bal[i].fre = 0;
        }
        while (n-- != 0){
            scanf("%s", s);
            t = hash(s);
            if (bal[t].fre != 0){
                ++bal[t].fre;
            }
            else{
                strcpy(bal[t].color, s);
                bal[t].fre = 1;
            }
        }
        max = 0;
        for (i=0; i<=N; ++i){
            if (bal[i].fre > max){
                max = bal[i].fre;
                max_i = i;
            }
        }
        printf("%s\n", bal[max_i].color);
    }
    return 0;
}




Host by is-Programmer.com | Power by Chito 1.3.3 beta | © 2007 LinuxGem | Design by Matthew "Agent Spork" McGee