杭电ACM 1028 Ignatius and the Princess III - neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。
杭电ACM 1028 Ignatius and the Princess III
neuxxm
posted @ 2011年5月20日 09:57
in 杭电ACM 解题报告
with tags
母函数
, 2443 阅读
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4193 Accepted Submission(s): 2931
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
#include <stdio.h> #include <string.h> #define N 120 int c1[N+1], c2[N+1]; int main(){ int i, j, k, n; for (i=0; i<=N; ++i){ c1[i] = 1; } for (k=2; k<=N; ++k){ memset(c2, 0, sizeof(c2)); for (i=0; i<=N; ++i){ for (j=i; j<=N; j+=k){ c2[j] += c1[i]; } } memcpy(c1, c2, sizeof(c2)); } while (scanf("%d", &n) == 1){ printf("%d\n", c1[n]); } return 0; }