杭电ACM 解题报告 - neuxxm's Blog - 本为贵公子,平生实爱才。感时思报国,拔剑起蒿莱。

杭电ACM 1001 Sum Problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 108140    Accepted Submission(s): 24596



 

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 


 

Input
The input will consist of a series of integers n, one integer per line.
 


 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 


 

Sample Input

	
1
100
 
Sample Output

	
1

5050

 

#include <stdio.h>
int main(){
    int n, sum;
    while (scanf("%d", &n) == 1){
        sum = 0;
        while (n != 0){
            sum += n--;
        }
        printf("%d\n\n", sum);
    }
    return 0;
}

杭电ACM 1000 A + B Problem

A + B Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 133394    Accepted Submission(s): 43158



 

Problem Description
Calculate A + B.
 


 

Input
Each line will contain two integers A and B. Process to end of file.
 


 

Output
For each case, output A + B in one line.
 


 

Sample Input

	
1 1
 
Sample Output

	
2

 

#include <stdio.h>
int main(){
    int x, y;
    while (scanf("%d %d", &x, &y) == 2){
        printf("%d\n", x+y);
    }
    return 0;
}




Host by is-Programmer.com | Power by Chito 1.3.3 beta | © 2007 LinuxGem | Design by Matthew "Agent Spork" McGee